summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xsrc/chroot-tools/librechroot17
-rw-r--r--src/lib/libremessages.1.ronn6
-rw-r--r--src/librefetch/librefetch.8.ronn10
3 files changed, 17 insertions, 16 deletions
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index ff764b6..1667d98 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -5,7 +5,7 @@ set -euE
# Copyright (C) 2010-2012 Nicolás Reynolds <fauno@parabola.nu>
# Copyright (C) 2011-2012 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
# Copyright (C) 2012 Michał Masłowski <mtjm@mtjm.eu>
-# Copyright (C) 2012-2017 Luke Shumaker <lukeshu@sbcglobal.net>
+# Copyright (C) 2012-2018 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv2+
#
@@ -73,16 +73,17 @@ hack_arch_nspawn_flags() {
# We're running an ARM chroot on a non-ARM processor
# Make sure that qemu-static is set up with binfmt_misc
- if [[ $(grep -c -xF \
- -e 'enabled' \
+ if [[ -z $(grep -l -xF \
-e 'interpreter /usr/bin/qemu-arm-static' \
- /proc/sys/fs/binfmt_misc/arm 2>/dev/null) -lt 2 ]]; then
+ -r -- /proc/sys/fs/binfmt_misc 2>/dev/null \
+ | xargs -r grep -xF 'enabled') ]]
+ then
error 'Cannot cross-compile for ARM on x86'
plain 'This requires a binfmt_misc entry for qemu-arm-static.'
prose 'Such a binfmt_misc entry is provided by the %s
package. If you have it installed, but still see
this message, you may need to restart %s.' \
- binfmt-qemu-static systemd-binfmt.service
+ qemu-user-static-binfmt systemd-binfmt.service
return $EXIT_NOTINSTALLED
fi
@@ -227,9 +228,9 @@ usage() {
echo
prose 'This command will make the following configuration changes in the
chroot:'
- bullet 'overwrite `/etc/libretools.d/chroot.conf`'
- bullet 'overwrite `/etc/pacman.d/mirrorlist`'
- bullet 'set `CacheDir` in `/etc/pacman.conf`'
+ bullet 'overwrite `/etc/libretools.d/chroot.conf`' # libretools/librechroot
+ bullet 'overwrite `/etc/pacman.d/mirrorlist`' # devtools/arch-nspawn
+ bullet 'set `CacheDir` in `/etc/pacman.conf`' # devtools/arch-nspawn
prose 'If a new `pacman.conf` is inserted with the `-C` flag, the change
is made after the file is copied in; the `-C` flag doesn'"'"'t
stop the change from being effective.'
diff --git a/src/lib/libremessages.1.ronn b/src/lib/libremessages.1.ronn
index 538a9b4..9c9377e 100644
--- a/src/lib/libremessages.1.ronn
+++ b/src/lib/libremessages.1.ronn
@@ -39,9 +39,9 @@ They are marked as readonly, so it is an error to try to set them
afterwards.
The following variables for numeric exit codes are set: a basic
-`EXIT_TRUE=0` and `EXIT_FALSE=1`, and well as several based on
-the [LSB recommendations for SysV init scripts][1]: `EXIT_SUCCESS`,
-`EXIT FAILURE`, `EXIT_INVALIDARGUMENT`, `EXIT_NOTIMPLEMENTED`,
+`EXIT_TRUE=0` and `EXIT_FALSE=1`, as well as several based on the
+[LSB recommendations for SysV init scripts][1]: `EXIT_SUCCESS`, `EXIT
+FAILURE`, `EXIT_INVALIDARGUMENT`, `EXIT_NOTIMPLEMENTED`,
`EXIT_NOPERMISSION`, `EXIT_NOTINSTALLED`, and `EXIT_NOTCONFIGURED`.
They are marked as readonly, so it is an error to try to set them
afterwards.
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index fa7aace..808c0fc 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -46,13 +46,13 @@ fails, it may choose to try `create` mode.
* `-p` <file>: Use an alternate build script for `create` mode
(instead of `PKGBUILD`). If an `SRCBUILD` file exists in the same
directory, it is used instead.
- * `-g` | `--geninteg`: Use `checksums` mode: Generate integrity
+ * `-g`, `--geninteg`: Use `checksums` mode: Generate integrity
checks for source files.
- * `-S` | `--srcbuild`: Use `srcbuild` mode: print the effective build
+ * `-S`, `--srcbuild`: Use `srcbuild` mode: Print the effective build
script.
- * `-M` | `--makepkg`: Use `makepkg` mode: generate and print the
+ * `-M`, `--makepkg`: Use `makepkg` mode: Generate and print the
location of the effective makepkg script.
- * `-h` | `--help`: Use `help` mode: Show usage information.
+ * `-h`, `--help`: Use `help` mode: Show usage information.
Other options, if they are documented in `makepkg -h`, are passed to
the modified copy of makepkg created during `create` mode.
@@ -64,7 +64,7 @@ the first value in <MIRRORS>, as configured in `librefetch.conf(5)`;
this is for compatibility with `PKGBUILD` files that used a previous
version of librefetch.
-It uses <DOWNLOADER>, as configured in `librefetch.conf` to attempt to
+It uses <DOWNLOADER>, as configured in `librefetch.conf`, to attempt to
download the source tarball from that URL. If that fails, and
following conditions are met, it proceeds to `create` mode: