summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..5be5195
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,39 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/config.mk
+include $(topsrcdir)/automake.head.mk
+
+# these are the resulting packages
+packages=libretools librelib gitget xbs
+# and which directories they contain
+libretools=\
+ src \
+ src/abslibre-tools \
+ src/chroot-tools \
+ src/devtools \
+ src/librefetch \
+ src/toru
+librelib=src/lib
+gitget=src/gitget
+xbs=\
+ src/xbs \
+ src/xbs-abs \
+ src/xbs-abslibre
+
+verbs=build install uninstall mostlyclean clean distclean maintainer-clean check
+$(foreach verb,$(verbs),$(foreach package,$(packages),$(eval $(verb)-$(package): $(addsuffix /$(verb),$($(package))))))
+$(foreach verb,$(verbs),$(foreach package,$(packages),$(eval .PHONY: $(verb)-$(package))))
+
+$(outdir)/check::
+ cd $(@D)/test && ./testenv $(TESTENVFLAGS) roundup
+
+_po_rule = \
+po/%(package).pot: $(addsuffix /everything.pot,$(%(package))); \
+ cat $^ | msguniq -Fi --to-code=UTF-8 > '$@' || rm -f '$@'
+$(foreach package,$(packages),$(eval $(subst %(package),$(package),$(value _po_rule))))
+
+pots =
+am_out_files += $(foreach package,$(packages),po/$(package).pot)
+am_clean_files += .var.*
+am_gen_files += .srcversion-libretools.mk .srcversion-devtools.mk
+am_subdirs = src $(foreach package,$(packages),$($(package)))
+
+include $(topsrcdir)/automake.tail.mk