summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index f6b78e9..5d7ece2 100644
--- a/Makefile
+++ b/Makefile
@@ -39,11 +39,8 @@ $(outdir)/shellcheck: private shellcheck.prune += -o -type f -name source.sh.gen
$(outdir)/shellcheck:
cd $(@D)/test && ./testenv $(TESTENVFLAGS) 'cd "$$TMPDIR/destdir" && find \( $(shellcheck.prune) \) -prune -o -not -type d -exec shellcheck $(shellcheck.flags) {} +'
-_po_rule = \
-$(srcdir)/po/%(pkg).pot: $(addsuffix /dir.pot,$(pkg.%(pkg))); \
- cat $^ | msguniq -Fi --to-code=UTF-8 > '$@'
$(eval $(foreach pkg,$(pkgs),\
- $(subst %(pkg),$(pkg),$(value _po_rule))$(at.nl)))
+ $(srcdir)/po/$(pkg).pot: $(addsuffix /dir.pot,$(pkg.$(pkg)))$(at.nl)))
libretools.out.mans =
libretools.out.bins =
@@ -51,7 +48,6 @@ libretools.out.libexecs =
libretools.out.libs =
libretools.out.docs =
libretools.out.confs =
-libretools.out = $(foreach pkg,$(pkgs),po/$(pkg).pot)
files.src.gen += .srcversion-libretools.mk .srcversion-devtools.mk
nested.subdirs = $(foreach pkg,$(pkgs),$(pkg.$(pkg))) po