summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 0 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
deleted file mode 100644
index ad92640..0000000
--- a/PKGBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Maintainer: Joshua Haase <hahj87@gmail.com
-# Contributor: fauno <fauno@kiwwwi.com.ar>
-
-pkgname=libretools
-pkgver=$(date +%Y%m%d)
-pkgrel=1
-pkgdesc="Scripts for easing Parabola's tasks"
-arch=('any')
-url="http://parabolagnulinux.org"
-license=('GPL3+')
-depends=(wget pacman devtools)
-makedepends=(git)
-backup=(etc/libretools.conf)
-install=libretools.install
-source=(libretools.install)
-md5sums=('07d2e7b0a1250d888fccc10969c7f436')
-
-_gitroot="http://projects.parabolagnulinux.org/libretools.git"
-_gitname="libretools"
-
-build() {
- cd "$srcdir"
- ## Git checkout
- if [ -d $srcdir/${_gitname} ] ; then
- msg "Git checkout: Updating existing tree"
- cd ${_gitname} && git pull origin
- msg "Git checkout: Tree has been updated"
- else
- msg "Git checkout: Retrieving sources"
- git clone ${_gitroot}
- fi
- msg "Checkout completed"
- ## Build
-}
-
-package() {
- install -d ${pkgdir}/usr/bin
- install -d ${pkgdir}/etc
-
- install -m644 ${_gitname}/libretools.conf ${pkgdir}/etc/
-
-
- install -m755 ${_gitname}/librechroot ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/librecommit ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/libremakepkg ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/librediff ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/librerelease ${pkgdir}/usr/bin/
- install -m755 ${_gitname}/pkgbuild-check-nonfree ${pkgdir}/usr/bin/
-
-}
-