summaryrefslogtreecommitdiff
path: root/abslibre-commit
diff options
context:
space:
mode:
Diffstat (limited to 'abslibre-commit')
-rwxr-xr-xabslibre-commit35
1 files changed, 35 insertions, 0 deletions
diff --git a/abslibre-commit b/abslibre-commit
new file mode 100755
index 0000000..8922cc0
--- /dev/null
+++ b/abslibre-commit
@@ -0,0 +1,35 @@
+#!/bin/bash
+# ABSLibreCommit
+# Commits a PKGBUILD to ABSLibre.git
+
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+for _pkg in ${@}; do
+ [[ ! -e ${_pkg}/PKGBUILD ]] && continue
+
+ unset pkgbase pkgname
+ source ${_pkg}/PKGBUILD
+
+ git stage ${_pkg}/*
+
+ git commit -m "${pkgbase:-$pkgname}-${pkgver}-${pkgrel}"
+done
+
+exit 0