summaryrefslogtreecommitdiff
path: root/aur
diff options
context:
space:
mode:
Diffstat (limited to 'aur')
-rwxr-xr-xaur11
1 files changed, 9 insertions, 2 deletions
diff --git a/aur b/aur
index a7408b7..35783c5 100755
--- a/aur
+++ b/aur
@@ -30,13 +30,18 @@ function usage {
while getopts 'h' arg; do
case $arg in
- h) usage; exit 0 ;;
- *) usage; exit 1 ;;
+ h) usage; exit 0 ;;
+ *) usage; exit 1 ;;
esac
done
missing_deps=()
for _pkg in ${@}; do
+
+# Remove the version
+# TODO check downloaded PKGBUILD version
+ _pkg="${_pkg%%[<>=]*}"
+
msg "Downloading $_pkg..."
wget -O - -q http://aur.archlinux.org/packages/$_pkg/$_pkg.tar.gz | \
tar xzf - >/dev/null 2>&1
@@ -75,6 +80,8 @@ for _pkg in ${@}; do
if ! find ${ABSROOT} -maxdepth 2 -type d -name "$_dep" | egrep "*" >/dev/null ; then
missing_deps=(${missing_deps} $_dep)
fi
+ else
+ msg2 "$_dep is on repos"
fi
done