summaryrefslogtreecommitdiff
path: root/aur
diff options
context:
space:
mode:
Diffstat (limited to 'aur')
-rwxr-xr-xaur6
1 files changed, 5 insertions, 1 deletions
diff --git a/aur b/aur
index ca7d587..1b17358 100755
--- a/aur
+++ b/aur
@@ -39,9 +39,13 @@ missing_deps=()
for _pkg in ${@}; do
# Remove the version
-# TODO check downloaded PKGBUILD version
_pkg="${_pkg%%[<>=]*}"
+ if [ -f "${_pkg}/PKGBUILD" ]; then
+ warning "${_pkg} already existed. skipping..."
+ continue
+ fi
+
msg "Downloading $_pkg..."
wget -O - -q http://aur.archlinux.org/packages/$_pkg/$_pkg.tar.gz | \
tar xzf - >/dev/null 2>&1