summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.head/20-libretools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.each.head/20-libretools.mk')
-rw-r--r--build-aux/Makefile.each.head/20-libretools.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/build-aux/Makefile.each.head/20-libretools.mk b/build-aux/Makefile.each.head/20-libretools.mk
new file mode 100644
index 0000000..90e9bda
--- /dev/null
+++ b/build-aux/Makefile.each.head/20-libretools.mk
@@ -0,0 +1,35 @@
+pkgconfdir = $(sysconfdir)/libretools.d
+pkgdocdir = $(docdir)/libretools
+pkglibexecdir = $(libexecdir)/libretools
+
+# Detect things about the directory we're in ####################################
+
+srcfiles-ignore/$(srcdir) = $(addsuffix /%,$(at.subdirs/$(@D)))
+
+ifeq ($(wildcard $(topsrcdir)/.git),)
+include $(srcdir)/.srcfiles.mk
+else
+$(srcdir)/.srcfiles.mk: FORCE
+ @echo srcfiles = $(filter-out $(srcfiles-ignore/$(@D)),$(shell cd $(@D) && git ls-files)) | $(WRITE_IFCHANGED) $@
+-include $(srcdir)/.srcfiles.mk
+endif
+
+detect-ignore =
+detect-ignore-exec =
+detect-ignore-conf =
+detect-ignore-ronn =
+detect-ignore-md = HACKING.md
+detect-ignore-sh =
+
+devtools-files =
+
+libretools-srcs = $(detect-all)
+libretools-mans = $(patsubst %.ronn,%,$(detect-ronn))
+libretools-bins = $(detect-exec)
+libretools-libexecs =
+libretools-libs = $(detect-sh)
+libretools-docs = $(detect-md) $(detect-ronn)
+libretools-confs = $(detect-conf)
+
+libretools-files = $(libretools-mans) $(libretools-bins) $(libretools-libexecs) $(libretools-libs) $(libretools-docs) $(libretools-confs)
+pots = $(libretools-bins) $(libretools-libexecs) $(libretools-libs)