summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.head/20-libretools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.each.head/20-libretools.mk')
-rw-r--r--build-aux/Makefile.each.head/20-libretools.mk59
1 files changed, 32 insertions, 27 deletions
diff --git a/build-aux/Makefile.each.head/20-libretools.mk b/build-aux/Makefile.each.head/20-libretools.mk
index 90e9bda..20abd8b 100644
--- a/build-aux/Makefile.each.head/20-libretools.mk
+++ b/build-aux/Makefile.each.head/20-libretools.mk
@@ -1,35 +1,40 @@
+# Copyright (C) 2017 Luke Shumaker
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
pkgconfdir = $(sysconfdir)/libretools.d
pkgdocdir = $(docdir)/libretools
pkglibexecdir = $(libexecdir)/libretools
-# Detect things about the directory we're in ####################################
-
-srcfiles-ignore/$(srcdir) = $(addsuffix /%,$(at.subdirs/$(@D)))
-
-ifeq ($(wildcard $(topsrcdir)/.git),)
-include $(srcdir)/.srcfiles.mk
-else
-$(srcdir)/.srcfiles.mk: FORCE
- @echo srcfiles = $(filter-out $(srcfiles-ignore/$(@D)),$(shell cd $(@D) && git ls-files)) | $(WRITE_IFCHANGED) $@
--include $(srcdir)/.srcfiles.mk
-endif
+# Auto-detect ########################################################
-detect-ignore =
-detect-ignore-exec =
-detect-ignore-conf =
-detect-ignore-ronn =
-detect-ignore-md = HACKING.md
-detect-ignore-sh =
+libretools.src.devtools =
-devtools-files =
+libretools.out.mans = $(patsubst %.ronn,%,$(libretools.src.ronn))
+libretools.out.bins = $(libretools.src.exec)
+libretools.out.libexecs =
+libretools.out.libs = $(libretools.src.sh)
+libretools.out.docs = $(libretools.src.md)
+libretools.out.confs = $(libretools.src.conf)
-libretools-srcs = $(detect-all)
-libretools-mans = $(patsubst %.ronn,%,$(detect-ronn))
-libretools-bins = $(detect-exec)
-libretools-libexecs =
-libretools-libs = $(detect-sh)
-libretools-docs = $(detect-md) $(detect-ronn)
-libretools-confs = $(detect-conf)
+libretools.out = $(libretools.out.mans)
+libretools.out += $(libretools.out.bins)
+libretools.out += $(libretools.out.libexecs)
+libretools.out += $(libretools.out.libs)
+libretools.out += $(libretools.out.docs)
+libretools.out += $(libretools.out.confs)
-libretools-files = $(libretools-mans) $(libretools-bins) $(libretools-libexecs) $(libretools-libs) $(libretools-docs) $(libretools-confs)
-pots = $(libretools-bins) $(libretools-libexecs) $(libretools-libs)
+libretools.pots = $(libretools.out.bins)
+libretools.pots += $(libretools.out.libexecs)
+libretools.pots += $(libretools.out.libs)