summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/10-files.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.each.tail/10-files.mk')
-rw-r--r--build-aux/Makefile.each.tail/10-files.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/build-aux/Makefile.each.tail/10-files.mk b/build-aux/Makefile.each.tail/10-files.mk
index 787a3bd..015a0ad 100644
--- a/build-aux/Makefile.each.tail/10-files.mk
+++ b/build-aux/Makefile.each.tail/10-files.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2017 Luke Shumaker
+# Copyright (C) 2015-2018 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -26,12 +26,14 @@ _files.all = $(_files.src) $(_files.out) $(_files.sys)
at.targets += $(subst *,%,$(_files.all))
+_files.groups := $(notdir $(filter-out $(at.targets),$(addprefix $(outdir)/,$(files.groups))))
+
# Creative targets
$(outdir)/$(files.generate): $(_files.src.gen) $(_files.src.cfg)
$(outdir)/install: $(_files.sys.$(files.default))
$(outdir)/installdirs: $(sort $(dir $(_files.sys)))
$(eval \
- $(foreach _files.g,$(files.groups),\
+ $(foreach _files.g,$(_files.groups),\
$$(outdir)/$(_files.g): $$(_files.out.$(_files.g))$(at.nl))\
$(foreach _files.g,$(filter-out $(files.default),$(files.groups)),\
$$(outdir)/install-$(_files.g): $$(_files.sys.$(_files.g))$(at.nl)))