summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/20-libretools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.each.tail/20-libretools.mk')
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
index c498396..1a6dc82 100644
--- a/build-aux/Makefile.each.tail/20-libretools.mk
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -59,16 +59,6 @@ $(outdir)/%.pot: $(srcdir)/% $(topsrcdir)/src/lib/librexgettext
$(outdir)/everything.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(libretools.pots)))
cat $^ | $(libretools.pofmt) > '$@'
-# If we have a .patch file, the flow is:
-# $(devtoolsdir)/%.in -> %.in + %.patch -> %.ugly -> %
-_do_patch = $(filter $(patsubst %.patch,%,$(filter %.patch,$(libretools.src.git))),$(patsubst %.in,%,$(libretools.src.devtools)))
-$(outdir)/%.ugly: $(srcdir)/%.in $(srcdir)/%.patch
- cp -T $< $@
- patch $@ $(<D)/$*.patch
-$(sort $(addprefix $(outdir)/,$(_do_patch))): $(outdir)/%: $(outdir)/%.ugly
- @echo 'EDIT < $< > $@'; $(libretools.edit) < '$<' | install -T -m$(if $(_is_executable),755,644) /dev/stdin '$@'
- @echo 'INDENT $@'; $(call libretools.indent,$@)
-
# Install rules ######################################################
$(DESTDIR)$(pkgconfdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'
$(DESTDIR)$(pkgdocdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'