summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.each.tail/20-libretools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.each.tail/20-libretools.mk')
-rw-r--r--build-aux/Makefile.each.tail/20-libretools.mk36
1 files changed, 21 insertions, 15 deletions
diff --git a/build-aux/Makefile.each.tail/20-libretools.mk b/build-aux/Makefile.each.tail/20-libretools.mk
index 945b0ea..9b1a6e3 100644
--- a/build-aux/Makefile.each.tail/20-libretools.mk
+++ b/build-aux/Makefile.each.tail/20-libretools.mk
@@ -21,23 +21,28 @@ endif
# Connect with `files` module ########################################
files.src.gen += $(libretools.src.devtools)
-files.out.all += $(filter-out $(files.src),$(libretools.out)) \
- $(if $(strip $(libretools.pots)),dir.pot)
-files.sys.all += $(addprefix $(bindir)/,$(libretools.out.bins)) \
- $(addprefix $(pkgconfdir)/,$(libretools.out.confs)) \
- $(addprefix $(pkglibdir)/,$(libretools.out.libs)) \
- $(addprefix $(pkglibexecdir)/,$(libretools.out.libexecs)) \
- $(addprefix $(docdir)/,$(libretools.out.docs)) \
- $(addprefix $(mandir)/man1/,$(filter %.1,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man2/,$(filter %.2,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man3/,$(filter %.3,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man4/,$(filter %.4,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man5/,$(filter %.5,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man6/,$(filter %.6,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man7/,$(filter %.7,$(libretools.out.mans))) \
- $(addprefix $(mandir)/man8/,$(filter %.8,$(libretools.out.mans)))
+files.out.$(libretools.pkg) += \
+ $(filter-out $(files.src),$(libretools.out)) \
+ $(if $(strip $(libretools.pots)),dir.pot)
+files.sys.$(libretools.pkg) += \
+ $(addprefix $(bindir)/,$(libretools.out.bins)) \
+ $(addprefix $(pkgconfdir)/,$(libretools.out.confs)) \
+ $(addprefix $(pkglibdir)/,$(libretools.out.libs)) \
+ $(addprefix $(pkglibexecdir)/,$(libretools.out.libexecs)) \
+ $(addprefix $(docdir)/,$(libretools.out.docs)) \
+ $(addprefix $(mandir)/man1/,$(filter %.1,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man2/,$(filter %.2,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man3/,$(filter %.3,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man4/,$(filter %.4,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man5/,$(filter %.5,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man6/,$(filter %.6,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man7/,$(filter %.7,$(libretools.out.mans))) \
+ $(addprefix $(mandir)/man8/,$(filter %.8,$(libretools.out.mans)))
files.out.int += *.pot *.ugly *.rej *.orig
+files.out.all += $(foreach pkg,$(filter-out all,$(files.groups)),$(files.out.$(pkg)))
+files.sys.all += $(foreach pkg,$(filter-out all,$(files.groups)),$(files.sys.$(pkg)))
+
# Generate rules #####################################################
$(srcdir)/%.in: $(devtoolsdir)/%.in
cp -T '$<' '$@'
@@ -57,6 +62,7 @@ $(srcdir)/%.pot: $(srcdir)/% $(topsrcdir)/src/lib/librexgettext
cd $(<D) && $(abspath $(topsrcdir)/src/lib/librexgettext) $(LIBREXGETTEXT_FLAGS) $(<F) > $(@F)
$(srcdir)/dir.pot: $(addprefix $(outdir)/,$(addsuffix .pot,$(libretools.pots)))
cat $^ | $(libretools.pofmt) > '$@'
+$(call at.path,$(topsrcdir)/po/$(libretools.pkg).pot): $(srcdir)/dir.pot
# Install rules ######################################################
$(DESTDIR)$(pkgconfdir)/% : $(outdir)/% ; install -T -Dm644 '$<' '$@'