summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/00-libretools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/00-libretools.mk')
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk11
1 files changed, 0 insertions, 11 deletions
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index 8497d68..1f2957d 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -37,7 +37,6 @@ define mod.libretools.doc
# - `var`
# - Shell commands (Global variables)
# - `libretools.edit`
-# - `libretools.indent`
# - `libretools.pofmt`
# - Source information
# - Directory variable : `libretools.src`
@@ -93,16 +92,6 @@ libretools.edit = sed \
-e 's|m4_include(lib/\(.*\))|. "$$(librelib \1)"|' \
$(foreach v,$(patsubst $(var.)%,%,$(filter $(var.)%,$^)), -e 's|@$(v)@|$($(v))|g' )
-# Usage: $(call libretools.indent,FILENAME)
-# Command to auto-indent a file.
-libretools.indent = emacs --batch $1 \
- --eval '(setq make-backup-files nil)' \
- --eval '(setq sh-basic-offset 8)' \
- --eval '(defun sh-smie-sh-rules--fix (args) "fix bug in Emacs 24 sh-script.el" (if (equal args (list :after "then")) (list :after "if") args))' \
- --eval "(advice-add 'sh-smie-sh-rules :filter-args \#'sh-smie-sh-rules--fix)" \
- --eval '(indent-region (point-min) (point-max) nil)' \
- -f save-buffer &>/dev/null
-
# Usage <INPUT $(libretools.pofmt) >OUTPUT
# Normalize a .po(t) file
libretools.pofmt = msguniq -Fi --to-code=UTF-8