summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/00-libretools.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/00-libretools.mk')
-rw-r--r--build-aux/Makefile.once.head/00-libretools.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/build-aux/Makefile.once.head/00-libretools.mk b/build-aux/Makefile.once.head/00-libretools.mk
index f3462d5..eb73476 100644
--- a/build-aux/Makefile.once.head/00-libretools.mk
+++ b/build-aux/Makefile.once.head/00-libretools.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015, 2017 Luke Shumaker
+# Copyright (C) 2015, 2017-2018 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -38,6 +38,7 @@ define mod.libretools.doc
# - `libretools.edit`
# - `libretools.pofmt`
# - Source information
+# - Directory variable : `libretools.pkg = libretools`
# - Directory variable : `libretools.src`
# - Directory variable : `libretools.src.exec`
# - Directory variable : `libretools.src.conf`
@@ -51,8 +52,11 @@ define mod.libretools.doc
# - Global variable : `DEVTOOLS_VERSION`
# - Global variable : `DEVTOOLS_COMMIT`
# - Primary outputs:
+# - Global variable : `files.groups`
# - Directory variable : `files.src.gen`
+# - Directory variable : `files.out.$(libretools.pkg)`
# - Directory variable : `files.out.all`
+# - Directory variable : `files.sys.$(libretools.pkg)`
# - Directory variable : `files.sys.all`
# - Directory variable : `files.out.int`
# - Target : `$(srcdir)/%.in: $(devtoolsdir)/%.in`
@@ -76,6 +80,7 @@ mod.quote.doc := $(value mod.quote.doc)
# Configure how Autothing modules work ###############################
gitfiles.file = .srcfiles.mk
+files.groups = all libretools librelib gitget xbs
# Boilerplate ########################################################
.PHONY: FORCE