summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head/10-nested.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head/10-nested.mk')
-rw-r--r--build-aux/Makefile.once.head/10-nested.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/build-aux/Makefile.once.head/10-nested.mk b/build-aux/Makefile.once.head/10-nested.mk
index d903d53..39c27e7 100644
--- a/build-aux/Makefile.once.head/10-nested.mk
+++ b/build-aux/Makefile.once.head/10-nested.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016-2017 Luke Shumaker
+# Copyright (C) 2016-2018 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -16,10 +16,11 @@
mod.nested.description = Easy nested .PHONY targets
define mod.nested.doc
# Inputs:
+# - Global variable : `at.targets`
# - Global variable : `nested.targets`
# - Directory variable : `nested.subdirs`
# Outputs:
-# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`
+# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`, unless $(outdir)/$(target) is already declared in $(at.targets)
# - Variable : `at.subdirs`
# - Variable : `at.targets`
#