summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.head
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.head')
-rw-r--r--build-aux/Makefile.once.head/10-files.mk5
-rw-r--r--build-aux/Makefile.once.head/10-nested.mk5
2 files changed, 6 insertions, 4 deletions
diff --git a/build-aux/Makefile.once.head/10-files.mk b/build-aux/Makefile.once.head/10-files.mk
index 564f9d6..9203d05 100644
--- a/build-aux/Makefile.once.head/10-files.mk
+++ b/build-aux/Makefile.once.head/10-files.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2015-2017 Luke Shumaker
+# Copyright (C) 2015-2018 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -22,6 +22,7 @@ define mod.files.doc
# - `RMDIR_P ?= rmdir -p --ignore-fail-on-non-empty`
# - `TRUE ?= true`
# Inputs:
+# - Global variable : `at.targets`
# - Global variable : `files.groups ?= all`
# - Global variable : `files.default ?= all`
# - Global variable : `files.vcsclean ?= files.vcsclean`
@@ -44,7 +45,7 @@ define mod.files.doc
# - Directory variable : `files.sys`
# - Creative .PHONY targets:
# - `$(outdir)/$(files.generate)`
-# - `$(outdir)/$(group)` for `group` in `$(files.groups)`
+# - `$(outdir)/$(group)` for `group` in `$(files.groups)`, unless $(outdir)/$(group) is already declared in $(at.targets)
# - `$(outdir)/install`
# - `$(outdir)/install-$(group)` for `group` in `$(filter-out $(files.default),$(files.groups))`
# - `$(outdir)/installdirs`
diff --git a/build-aux/Makefile.once.head/10-nested.mk b/build-aux/Makefile.once.head/10-nested.mk
index d903d53..39c27e7 100644
--- a/build-aux/Makefile.once.head/10-nested.mk
+++ b/build-aux/Makefile.once.head/10-nested.mk
@@ -1,4 +1,4 @@
-# Copyright (C) 2016-2017 Luke Shumaker
+# Copyright (C) 2016-2018 Luke Shumaker
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as published by
@@ -16,10 +16,11 @@
mod.nested.description = Easy nested .PHONY targets
define mod.nested.doc
# Inputs:
+# - Global variable : `at.targets`
# - Global variable : `nested.targets`
# - Directory variable : `nested.subdirs`
# Outputs:
-# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`
+# - .PHONY Targets : `$(addprefix $(outdir)/,$(nested.targets))`, unless $(outdir)/$(target) is already declared in $(at.targets)
# - Variable : `at.subdirs`
# - Variable : `at.targets`
#