summaryrefslogtreecommitdiff
path: root/build-aux/Makefile.once.tail
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux/Makefile.once.tail')
-rw-r--r--build-aux/Makefile.once.tail/00-dist.mk2
-rw-r--r--build-aux/Makefile.once.tail/00-mod.mk32
-rw-r--r--build-aux/Makefile.once.tail/00-noop.mk2
3 files changed, 1 insertions, 35 deletions
diff --git a/build-aux/Makefile.once.tail/00-dist.mk b/build-aux/Makefile.once.tail/00-dist.mk
index 6c6aaed..3fbe0c4 100644
--- a/build-aux/Makefile.once.tail/00-dist.mk
+++ b/build-aux/Makefile.once.tail/00-dist.mk
@@ -15,7 +15,7 @@
_dist.copyfile = $(MKDIR_P) $(dir $2) && $(CP) -T $1 $2
_dist.addfile = $(call _dist.copyfile,$3,$2/$(call at.relto,$1,$3))
-$(topoutdir)/$(dist.pkgname)-$(dist.version): $(foreach v,$(filter std.src_files/% std.gen_files/%,$(.VARIABLES)),$($v))
+$(topoutdir)/$(dist.pkgname)-$(dist.version): $(_dist.files)
$(RM) -r $@ $(@D)/.tmp.$(@F)
$(MKDIR) $(@D)/.tmp.$(@F)
$(foreach f,$^,$(call _dist.addfile,$(topsrcdir),$(@D)/.tmp.$(@F),$f)$(at.nl))
diff --git a/build-aux/Makefile.once.tail/00-mod.mk b/build-aux/Makefile.once.tail/00-mod.mk
deleted file mode 100644
index 68350f0..0000000
--- a/build-aux/Makefile.once.tail/00-mod.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright (C) 2016 Luke Shumaker
-#
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-$(_mod.target):
- @printf 'Autothing modules used in this project:\n'
- @printf ' - %s\n' $(foreach _mod.tmp,$(_mod.modules),$(call _mod.quote,$(_mod.tmp)))
-$(addprefix $(_mod.target)/,$(_mod.modules)): $(_mod.target)/%:
- @printf 'Module : %s ' $(call _mod.quote,$*)
- @$(if $(at.mod.$*.description),printf ' - %s' $(call _mod.quote,mod.$*.description))
- @echo
- @echo Depends on : $(mod.$*.depends)
- @echo User configuration:
- @egrep '^\s*[^:#]+\s*\?=' $(topsrcdir)/build-aux/Makefile.once.head/??-$*.mk 2>/dev/null | sed 's|^\s*||;s|?=|:' | grep -v -e ^'_' -e ^'$*' | column -t -s: |sed 's|^| |'
- @echo Developer global inputs:
- @egrep '^\s*[^:#]+\s*\?=' $(topsrcdir)/build-aux/Makefile.once.head/??-$*.mk 2>/dev/null | sed 's|^\s*||;s|?=|:' | grep ^'$*\.' | column -t -s: |sed 's|^| |'
- @echo Developer per-directory inputs:
- @egrep '^\s*[^:#]+\s*\?=' $(topsrcdir)/build-aux/Makefile.each.head/??-$*.mk 2>/dev/null | sed 's|^\s*||;s|?=|:' | grep ^'$*\.' | column -t -s: |sed 's|^| |'
- @echo Developer outputs:
- @egrep '^\s*[^:#]+\s*(|:|::)=' $(topsrcdir)/build-aux/Makefile.once.head/??-$*.mk 2>/dev/null | sed 's|^\s*||;s|?=|:' | grep ^'$*\.' | column -t -s: |sed 's|^| |'
-.PHONY: $(addprefix mod/,$(_mod.modules))
diff --git a/build-aux/Makefile.once.tail/00-noop.mk b/build-aux/Makefile.once.tail/00-noop.mk
deleted file mode 100644
index bac2ec1..0000000
--- a/build-aux/Makefile.once.tail/00-noop.mk
+++ /dev/null
@@ -1,2 +0,0 @@
-noop:
-.PHONY: noop