summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/Makefile.each.tail/00-dist.mk4
-rw-r--r--build-aux/Makefile.once.head/00-dist.mk6
-rw-r--r--build-aux/Makefile.once.tail/00-dist.mk6
3 files changed, 8 insertions, 8 deletions
diff --git a/build-aux/Makefile.each.tail/00-dist.mk b/build-aux/Makefile.each.tail/00-dist.mk
index d85ecc0..a094305 100644
--- a/build-aux/Makefile.each.tail/00-dist.mk
+++ b/build-aux/Makefile.each.tail/00-dist.mk
@@ -14,7 +14,7 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
ifeq ($(outdir),$(topoutdir))
-std.clean_files += $(addprefix $(dist.name)-*,$(dist.exts) .tar /)
+std.clean_files += $(addprefix $(dist.pkgname)-*,$(dist.exts) .tar /)
endif
-$(outdir)/dist: $(addprefix $(topoutdir)/$(dist.name)-$(dist.version),$(dist.exts))
+$(outdir)/dist: $(addprefix $(topoutdir)/$(dist.pkgname)-$(dist.version),$(dist.exts))
diff --git a/build-aux/Makefile.once.head/00-dist.mk b/build-aux/Makefile.once.head/00-dist.mk
index 2f1da66..d5bfcd3 100644
--- a/build-aux/Makefile.once.head/00-dist.mk
+++ b/build-aux/Makefile.once.head/00-dist.mk
@@ -16,11 +16,11 @@
# Developer configuration
dist.exts ?= .tar.gz
-dist.name ?= $(PACKAGE)
+dist.pkgname ?= $(PACKAGE)
dist.version ?= $(VERSION)
-ifeq ($(dist.name),)
-$(error dist.name must be set)
+ifeq ($(dist.pkgname),)
+$(error dist.pkgname must be set)
endif
ifeq ($(dist.version),)
$(error dist.version must be set)
diff --git a/build-aux/Makefile.once.tail/00-dist.mk b/build-aux/Makefile.once.tail/00-dist.mk
index ee28fac..3990f57 100644
--- a/build-aux/Makefile.once.tail/00-dist.mk
+++ b/build-aux/Makefile.once.tail/00-dist.mk
@@ -15,14 +15,14 @@
_dist.copyfile = $(MKDIR_P) $(dir $2) && $(CP) -T $1 $2
_dist.addfile = $(call _dist.copyfile,$3,$2/$(call at.relto,$1,$3))
-$(topoutdir)/$(dist.name)-$(dist.version): $(std.src_files/$(topoutdir)) $(std.gen_files/$(topoutdir))
+$(topoutdir)/$(dist.pkgname)-$(dist.version): $(std.src_files/$(topoutdir)) $(std.gen_files/$(topoutdir))
$(RM) -r $@
@PS4='' && set -x && \
$(MKDIR) $(@D)/tmp.$(@F).$$$$ && \
$(foreach f,$^,$(call _dist.addfile,$(topsrcdir),$(@D)/tmp.$(@F).$$$$,$f) &&) \
$(MV) $(@D)/tmp.$(@F).$$$$ $@ || $(RM) -r $(@D)/tmp.$(@F).$$$$
-$(topoutdir)/$(dist.name)-$(dist.version).tar: $(topoutdir)/$(dist.name)-$(dist.version)
+$(topoutdir)/$(dist.pkgname)-$(dist.version).tar: $(topoutdir)/$(dist.pkgname)-$(dist.version)
$(TAR) cf $@ -C $(<D) $(<F)
-$(topoutdir)/$(dist.name)-$(dist.version).tar.gz: $(topoutdir)/$(dist.name)-$(dist.version).tar
+$(topoutdir)/$(dist.pkgname)-$(dist.version).tar.gz: $(topoutdir)/$(dist.pkgname)-$(dist.version).tar
$(GZIP) $(GZIPFLAGS) < $< > $@