summaryrefslogtreecommitdiff
path: root/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'common.mk')
-rw-r--r--common.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/common.mk b/common.mk
index ea89de1..deb64c7 100644
--- a/common.mk
+++ b/common.mk
@@ -81,8 +81,8 @@ build: PHONY $(build_files)
ronn --html $(RONNFLAGS) < '$<' > '$@'
%: %.in
@echo "GEN $@"
- @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
- @chmod 755 "$@" || { rm -f -- '$@'; false; }
+ @$(edit) <"$<" >"$@"
+ @chmod 755 "$@"
# Build ########################################################################
@@ -146,3 +146,5 @@ clean-hook: PHONY
FORCE: PHONY
PHONY:
.PHONY: FORCE PHONY
+
+.DELETE_ON_ERROR: