summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 7af3750..4e496f3 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -1,2 +1,16 @@
-libre_datadir=$(docdir)/libretools
-include ../common.mk
+topdir := $(realpath ..)
+include $(topdir)/config.mk
+
+files = $(wildcard *.md)
+
+all: PHONY build
+build: PHONY
+
+install: $(addprefix $(DESTDIR)$(docdir)/libretools/,$(files))
+
+$(DESTDIR)$(docdir)/libretools/%: %
+ install -Dm644 '$<' '$@'
+
+FORCE: PHONY
+PHONY:
+.PHONY: FORCE PHONY