summaryrefslogtreecommitdiff
path: root/fullpkg-find
diff options
context:
space:
mode:
Diffstat (limited to 'fullpkg-find')
-rwxr-xr-xfullpkg-find11
1 files changed, 1 insertions, 10 deletions
diff --git a/fullpkg-find b/fullpkg-find
index 2f3aaaa..e188ec8 100755
--- a/fullpkg-find
+++ b/fullpkg-find
@@ -11,14 +11,6 @@ guess_repo() {
basename $(dirname $(pwd))
}
-# Finds a PKGBUILD on toru's path cache
-# Look in all caches but pick the first one
-# TODO move to a toru flag (-p?)
-where_is() {
- grep -m1 "^${1}:" "${TORUPATH}/paths" 2>/dev/null| \
- cut -d: -f2 2>/dev/null
-}
-
# return : full version spec, including epoch (if necessary), pkgver, pkgrel
# usage : get_fullver( ${epoch:-0}, $pkgver, $pkgrel )
get_fullver() {
@@ -114,10 +106,9 @@ find_deps() {
for _dep in ${deps[@]}; do
local found=false
-# TODO change for where_is or toru-path
# May fail, e.g. since abslibre-mips64el doesn't include
# arch=any packages.
- local pkgdir=$(where_is ${_dep}) || true
+ local pkgdir=$(toru -p ${_dep}) || true
if [ -n "$pkgdir" -a -d "${pkgdir}" ]; then
found=true