summaryrefslogtreecommitdiff
path: root/fullpkg-find
diff options
context:
space:
mode:
Diffstat (limited to 'fullpkg-find')
-rwxr-xr-xfullpkg-find16
1 files changed, 5 insertions, 11 deletions
diff --git a/fullpkg-find b/fullpkg-find
index 8c0c063..9ddfa08 100755
--- a/fullpkg-find
+++ b/fullpkg-find
@@ -80,17 +80,16 @@ find_deps() {
local found=false
# TODO change for where_is or toru-path
- local pkgdir=$(toru -p ${_dep})
+ # May fail, e.g. since abslibre-mips64el doesn't include
+ # arch=any packages.
+ local pkgdir=$(toru -p ${_dep}) || true
if [ -n "$pkgdir" -a -d "${pkgdir}" ]; then
found=true
pushd "${pkgdir}" > /dev/null
# runs itself on dep's PKGBUILD dir
- $0 -l ${next_level} ${build_dir}
-
-# probable circular deps
- [ $? -eq 20 ] && return 20
+ $0 -l ${next_level} ${build_dir} || return $?
popd > /dev/null
fi
@@ -188,13 +187,8 @@ fi
find_deps || {
# Probable circular deps
- if [ "$?" -eq 20 ]; then
-
-# Show error only on level 0
- if [ "$LEVEL" -eq 0 ]; then
+ if [ "$?" -eq 20 -a "$LEVEL" -eq 0 ]; then
error "Check for circular deps on $build_dir/BUILDORDER";
- fi
-
fi
# Pass message 20
exit 20