summaryrefslogtreecommitdiff
path: root/fullpkg
diff options
context:
space:
mode:
Diffstat (limited to 'fullpkg')
-rwxr-xr-xfullpkg16
1 files changed, 9 insertions, 7 deletions
diff --git a/fullpkg b/fullpkg
index b7f09ba..264a910 100755
--- a/fullpkg
+++ b/fullpkg
@@ -156,7 +156,7 @@ function find_deps {
# If package and correct ${fullver} is built exit
# TODO?: If this package is in force_build: skip this step
- if is_built "${pkgbase}=${fullver}"; then
+ if is_built "${pkgbase}>=${fullver}"; then
exit 0
fi
@@ -411,6 +411,13 @@ if ! grep mips64el PKGBUILD >/dev/null; then
sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" "PKGBUILD"
fi
+# If the queue file isn't writable go into offline mode
+[ ! -w $queue_file ] && {
+ error "Can't write queue file"
+ OFFLINE=true
+}
+
+
# Only on level 0
if [ $level -eq 0 ]; then
# if build_dir exist use it, else make a build_dir
@@ -427,6 +434,7 @@ if [ $level -eq 0 ]; then
# Build only
[ ${build_only} == 'y' ] && {
+ msg "Build Packages"
_pkg_build
exit 0
}
@@ -477,12 +485,6 @@ find_deps || {
## START Building
msg "Building packages:"
-# If the queue file isn't writable go into offline mode
-[ ! -w $queue_file ] && {
- error "Can't write queue file"
- OFFLINE=true
-}
-
# Build the package
_pkg_build