summaryrefslogtreecommitdiff
path: root/librerelease
diff options
context:
space:
mode:
Diffstat (limited to 'librerelease')
-rwxr-xr-xlibrerelease21
1 files changed, 11 insertions, 10 deletions
diff --git a/librerelease b/librerelease
index 01d8d81..4662ced 100755
--- a/librerelease
+++ b/librerelease
@@ -1,6 +1,6 @@
#!/bin/bash
# Librerelease
-# Uploads packages into free/ repo
+# Uploads packages into [staging]
# Copyright 2010 Nicolás Reynolds
@@ -20,12 +20,12 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+
+source /etc/libretools.conf
+
custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
-if [ -e $custom_config ]; then
- source $custom_config
-else
- source /etc/libretools.conf
-fi
+[[ -e $custom_config ]] && source $custom_config
batchfile=/tmp/librerelease_batchfile.$$
# End Config
@@ -48,16 +48,17 @@ function to_sftp() {
echo "$@" >> $batchfile
}
-if [ ! -e ./PKGBUILD ]; then
+[[ ! -e ./PKGBUILD ]] && {
echo "PKGBUILD not found"
- exit 1;
-fi
+ exit 1
+}
source PKGBUILD
source /etc/makepkg.conf
-if [ -e ~/.makepkg.conf ]; then source ~/.makepkg.conf; fi
+[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
+# Default package location
PKGDEST=${PKGDEST:-.}
SRCPKGDEST=${SRCPKGDEST:-.}