summaryrefslogtreecommitdiff
path: root/librerepkg
diff options
context:
space:
mode:
Diffstat (limited to 'librerepkg')
-rwxr-xr-xlibrerepkg5
1 files changed, 3 insertions, 2 deletions
diff --git a/librerepkg b/librerepkg
index 647a7c0..706b603 100755
--- a/librerepkg
+++ b/librerepkg
@@ -36,7 +36,7 @@ source rePKGBUILD
usage() {
echo "cd to a dir with a rePKGBUILD and other file info and run"
- echo "$0 "
+ echo "$0 [makepkg flags]"
echo
echo "This script will repackage an arch package without compiling"
}
@@ -44,6 +44,7 @@ usage() {
while getopts 'h' arg; do
case $arg in
h) usage; exit 0 ;;
+ *) makepkgflags=$@ ;;
esac
done
@@ -58,6 +59,6 @@ msg2 "Updating md5sums"
makepkg -gp rePKGBUILD >> rePKGBUILD
msg "Repackaging using makepkg"
-makepkg -Lcdp rePKGBUILD $@
+makepkg -Lcdp rePKGBUILD ${makepkgflags}
stdnull popd ${tempdir}