summaryrefslogtreecommitdiff
path: root/librerepkg
diff options
context:
space:
mode:
Diffstat (limited to 'librerepkg')
-rw-r--r--librerepkg19
1 files changed, 19 insertions, 0 deletions
diff --git a/librerepkg b/librerepkg
index f943c2a..53751e4 100644
--- a/librerepkg
+++ b/librerepkg
@@ -19,4 +19,23 @@
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
source /etc/libretools.conf
+custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
+if [ -x $custom_config ]; then
+ source $custom_config;
+ unset $custom_config
+fi
+[[ ! -r rePKGBUILD ]] && {
+ error "This build does not contains a rePKGBUILD."
+ exit 1
+}
+
+source /etc/makepkg.conf
+source /etc/abs.conf
+
+stdnull "tempdir=$(mktemp -d /tmp/$(basename $PWD).XXXXX)"
+
+cp rePKGBUILD ${tempdir}/PKGBUILD
+pushd ${tempdir}
+msg Building using libremakepkg
+sudo libremakepkg