summaryrefslogtreecommitdiff
path: root/librestage
diff options
context:
space:
mode:
Diffstat (limited to 'librestage')
-rwxr-xr-xlibrestage12
1 files changed, 6 insertions, 6 deletions
diff --git a/librestage b/librestage
index 70aaa4a..f75d101 100755
--- a/librestage
+++ b/librestage
@@ -50,7 +50,7 @@ if [ ${#repos} -eq 0 ]; then
fi
[[ ! -e ./PKGBUILD ]] && {
- echo "PKGBUILD not found"
+ error "PKGBUILD not found"
exit 1
}
@@ -70,7 +70,7 @@ for _arch in ${arch[@]}; do
pkgpath="$PKGDEST/$pkgfile"
if [ -e "${pkgpath}" ]; then
- echo found ${pkgfile}
+ msg "Found ${pkgfile}"
canonical=""
for _repo in ${repos[@]}; do
@@ -78,17 +78,17 @@ for _arch in ${arch[@]}; do
[[ -z "$canonical" ]] && {
canonical="${WORKDIR}/staging/${_repo}/${pkgfile}"
cp "${pkgpath}" "${WORKDIR}/staging/${_repo}/" || {
- echo "Can't put ${pkgfile} on [staging]"
+ error "Can't put ${pkgfile} on [staging]"
exit 1
} && {
- echo "${pkg} staged on [${_repo}]"
+ msg2 "${pkg} staged on [${_repo}]"
}
} || {
ln "${canonical}" "${WORKDIR}/staging/${_repo}/${pkgfile}" || {
- echo "Can't put ${pkgfile} on [staging]"
+ error "Can't put ${pkgfile} on [staging]"
exit 1
} && {
- echo "${pkg} staged on [${_repo}]"
+ msg2 "${pkg} staged on [${_repo}]"
}
}
done