summaryrefslogtreecommitdiff
path: root/pkgbuild-check-nonfree
diff options
context:
space:
mode:
Diffstat (limited to 'pkgbuild-check-nonfree')
-rwxr-xr-xpkgbuild-check-nonfree14
1 files changed, 5 insertions, 9 deletions
diff --git a/pkgbuild-check-nonfree b/pkgbuild-check-nonfree
index 6f3837b..178cd0f 100755
--- a/pkgbuild-check-nonfree
+++ b/pkgbuild-check-nonfree
@@ -56,18 +56,14 @@ source ./PKGBUILD
# The `pkgname', `depends', `makedepends' arrays have been sourced from
# ./PKGBUILD.
msg "Looking for unfree dependencies"
-for where in pkgname depends makedepends ; do
- msg2 " Cheking in «${where}»:"
-
+for item in (${pkgname[@]} ${depends[@]} ${makedepends[@]}) ; do
# We cycle through all of the programs in the array (if any), and check if
# they are in the `unfree' array.
- for item in ${!where[@]} ; do
- if in_array $item ${unfree[@]}
+ if in_array $item ${unfree[@]}
then
- ev=15
- plain $item
- fi
- done
+ ev=15
+ msg2 "found $item"
+ fi
done
exit $ev \ No newline at end of file