summaryrefslogtreecommitdiff
path: root/po/HACKING
diff options
context:
space:
mode:
Diffstat (limited to 'po/HACKING')
-rw-r--r--po/HACKING23
1 files changed, 13 insertions, 10 deletions
diff --git a/po/HACKING b/po/HACKING
index 9ab35a7..5dd207c 100644
--- a/po/HACKING
+++ b/po/HACKING
@@ -2,23 +2,24 @@ Translations for programs are provided in files with the `.po` suffix.
These are created by copying PO-template (`.pot`) files, and filling
in the missing "msgstr" values.
-To add a translation, you'll first (1) need to create the `.pot`
-files, and then (2) copy them and (3) fill them in.
+To add a translation, you'll first (1) need to create the `.pot` files
+if you don't already have them, and then (2) copy them and (3) fill
+them in.
# 1. Create `.pot` files
+ If you are working from a release source tarball, you can skip this
+ step (the `.pot` files are included in the tarball); if you are
+ working from git, read on.
+
libretools' .pot files are not tracked in git; they are created by
- running `make` (you'll need a checkout of both devtools-par and
- libretools to run `make` if building from git). In addition to the
- usual (`base-devel`) depenencies when running `make`, you'll need
- the `ruby-ronn` package as well.
+ running `make`. You'll need a checkout of both "devtools-par" and
+ "libretools" to run `make` if building from git.
- $ sudo pacman -S --needed base-devel ruby-ronn
- ...
$ git clone https://git.parabola.nu/packages/devtools-par.git/
$ git clone https://git.parabola.nu/packages/libretools.git/
$ cd libretools
- $ make
+ $ make po/files.generate
...
$ cd po/
$ ls
@@ -33,10 +34,12 @@ files, and then (2) copy them and (3) fill them in.
Create a folder under `po/` with the two-letter language code[^1]
you want to add. Then, copy the `.pot` files to that folder,
- changing the file extension to `.po`; for example:
+ changing the file extension to `.po`. Finally, link the `subdir.mk`
+ file to be the Makefile for that directory. For example:
$ mkdir es
$ for file in *.pot; do cp $file es/${file%t}; done
+ $ ln -s ../subdir.mk es/Makefile
[^1]: See the langauge code table
here: <http://www.lingoes.net/en/translator/langcode.htm>