summaryrefslogtreecommitdiff
path: root/po/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'po/Makefile')
-rw-r--r--po/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/po/Makefile b/po/Makefile
index 1e56edd..96d8490 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -6,6 +6,16 @@ locales := $(filter-out .,$(sort $(patsubst %/,%,$(dir $(files.src.src)))))
files.src.gen += $(addsuffix .pot,$(domains))
nested.subdirs += $(locales)
+
+# Have the header include the version number
+$(srcdir)/header.po.head: $(srcdir)/%: $(srcdir)/%.in
+ @echo 'EDIT < $< > $@'; $(libretools.edit) < '$<' > '$@'
+$(srcdir)/header.po.head: $(var.)PACKAGE $(var.)VERSION
+files.src.int += header.po.head
+
+# Rely on ../Makefile to fill in a list of our .pot dependencies
+$(srcdir)/%.pot: $(srcdir)/header.po.head
+ cat $^ | msguniq -Fi > '$@'
at.subdirs += ..
include $(topsrcdir)/build-aux/Makefile.tail.mk