summaryrefslogtreecommitdiff
path: root/po/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'po/Makefile')
-rw-r--r--po/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/po/Makefile b/po/Makefile
index 96d8490..b27844c 100644
--- a/po/Makefile
+++ b/po/Makefile
@@ -15,7 +15,13 @@ files.src.int += header.po.head
# Rely on ../Makefile to fill in a list of our .pot dependencies
$(srcdir)/%.pot: $(srcdir)/header.po.head
- cat $^ | msguniq -Fi > '$@'
+ @echo 'MSGCAT $^ > $@';
+ @{ \
+ cd $(topsrcdir) && \
+ for file in $(call at.relto,$(topsrcdir),$^); do \
+ sed "/^#:/s, , $${file%/*}/,g" <"$$file"; \
+ done; \
+ } | msguniq -Fi > '$@'
at.subdirs += ..
include $(topsrcdir)/build-aux/Makefile.tail.mk