summaryrefslogtreecommitdiff
path: root/rePKGBUILD.proto
diff options
context:
space:
mode:
Diffstat (limited to 'rePKGBUILD.proto')
-rw-r--r--rePKGBUILD.proto29
1 files changed, 29 insertions, 0 deletions
diff --git a/rePKGBUILD.proto b/rePKGBUILD.proto
new file mode 100644
index 0000000..c8b19bf
--- /dev/null
+++ b/rePKGBUILD.proto
@@ -0,0 +1,29 @@
+# This is an example rePKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+source PKGBUILD
+unset build package md5sums source
+_repo= # Put the repo here
+_mirror=http://mirrors.kernel.org/archlinux # Put mirror here
+source=(PKGBUILD
+ "${_mirror}/${_repo}/os/${CARCH}/${pkgname%-libre}-$pkgver-$pkgrel-$CARCH$PKGEXT"
+ # files for pkg modifications below this line
+ )
+
+build() {
+ cd "${srcdir}/"
+ rm .{INSTALL,PKGINFO}
+ # put actions for package modifications below this line
+
+}
+
+package() {
+ find ${srcdir} -maxdepth 1 -type l -delete
+ cp -a ${srcdir}/* ${pkgdir}
+}
+
+
+# vim:set ts=2 sw=2 et: