summaryrefslogtreecommitdiff
path: root/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile')
-rw-r--r--src/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile b/src/Makefile
index 273a34b..2ba9534 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -1,7 +1,11 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+
pkgconfdir = $(sysconfdir)
-srcfiles-ignore/$(srcdir) = $(addsuffix /%,abslibre-tools chroot-tools devtools gitget lib librefetch toru xbs xbs-abs xbs-abslibre)
+# Because against all common sense, the subdirectories of this
+# directory aren't `nested.subdirs`, gitfiles includes the files in
+# them in `files.src.src`. So, filter-out everything with a slash.
+files.src.src := $(foreach f,$(files.src.src),$(if $(findstring /,$f),, $f ))
include $(topsrcdir)/build-aux/Makefile.tail.mk