summaryrefslogtreecommitdiff
path: root/src/abslibre-tools/librestage
diff options
context:
space:
mode:
Diffstat (limited to 'src/abslibre-tools/librestage')
-rwxr-xr-xsrc/abslibre-tools/librestage10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index ae66cce..c0936cc 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -22,9 +22,10 @@
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-source /etc/libretools.conf
-custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
-[[ -e $custom_config ]] && source $custom_config
+. libremessages
+. $(librelib conf.sh)
+load_files libretools
+check_vars libretools ARCHES WORKDIR || exit 1
if [ -w / ]; then
error "This script should be run as regular user"
@@ -68,8 +69,7 @@ fi
}
# Source the needed files
-source /etc/makepkg.conf
-[[ -e ~/.makepkg.conf ]] && source ~/.makepkg.conf
+load_files makepkg
source ./PKGBUILD
[[ -e ./rePKGBUILD ]] && source ./rePKGBUILD