summaryrefslogtreecommitdiff
path: root/src/abslibre-tools
diff options
context:
space:
mode:
Diffstat (limited to 'src/abslibre-tools')
-rwxr-xr-xsrc/abslibre-tools/librerelease2
-rwxr-xr-xsrc/abslibre-tools/librestage10
2 files changed, 6 insertions, 6 deletions
diff --git a/src/abslibre-tools/librerelease b/src/abslibre-tools/librerelease
index 38fa0ac..08960bc 100755
--- a/src/abslibre-tools/librerelease
+++ b/src/abslibre-tools/librerelease
@@ -99,7 +99,7 @@ function clean {
function main {
if [ -w / ]; then
- error "Run $0 as normal user"
+ error "This program should be run as regular user"
exit 1
fi
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index 52e761a..0cb7a27 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -34,6 +34,11 @@ usage() {
}
main() {
+ if [[ -w / ]]; then
+ error "This program should be run as regular user"
+ return 1
+ fi
+
# Parse options, set up
while getopts 'h' arg; do
case $arg in
@@ -47,11 +52,6 @@ main() {
return 1;
fi
- if [[ -w / ]]; then
- error "This script should be run as regular user"
- return 1
- fi
-
[[ ! -e ./PKGBUILD ]] && {
error "PKGBUILD not found"
return 1