summaryrefslogtreecommitdiff
path: root/src/abslibre-tools
diff options
context:
space:
mode:
Diffstat (limited to 'src/abslibre-tools')
-rwxr-xr-xsrc/abslibre-tools/libreaddiff7
-rwxr-xr-xsrc/abslibre-tools/librestage2
2 files changed, 2 insertions, 7 deletions
diff --git a/src/abslibre-tools/libreaddiff b/src/abslibre-tools/libreaddiff
index fafdada..e31cc7b 100755
--- a/src/abslibre-tools/libreaddiff
+++ b/src/abslibre-tools/libreaddiff
@@ -68,12 +68,7 @@ except StopIteration:
# Needed to not include pkgnames specific to other arches.
CARCH=$arch
for f in $repo/* ; do
- unset pkgname
- unset epoch
- unset pkgver
- unset pkgrel
- unset arch
- . $f/PKGBUILD || continue
+ load_PKGBUILD "$f/PKGBUILD" || continue
is_here=false
for arc in ${arch[@]} ; do
if [ "$arc" = "any" -o "$arc" = "$CARCH" ] ; then
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index 6eba8dd..e67e98f 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -63,7 +63,7 @@ main() {
load_files makepkg # for PKGDEST, which is optional
# Load the PKGBUILD
- source ./PKGBUILD
+ load_PKGBUILD
# Now for the main routine.
staged=false