summaryrefslogtreecommitdiff
path: root/src/chroot-tools/chcleanup.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/chroot-tools/chcleanup.in')
-rw-r--r--src/chroot-tools/chcleanup.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/chroot-tools/chcleanup.in b/src/chroot-tools/chcleanup.in
index 700c8b5..55ab9bf 100644
--- a/src/chroot-tools/chcleanup.in
+++ b/src/chroot-tools/chcleanup.in
@@ -68,7 +68,7 @@ if [[ -f ./PKGBUILD ]]; then
if [[ ! -f ./.SRCINFO || ./PKGBUILD -nt ./.SRCINFO ]]; then
sudo -u "#$(stat -c %u -- ./PKGBUILD)" sh -c 'makepkg --printsrcinfo > .SRCINFO'
fi
- CARCH="$(. /etc/makepkg.conf; printf '%s' "$CARCH")"
+ CARCH="$(source /etc/makepkg.conf; printf '%s' "$CARCH")"
mapfile -t DEPENDS < <(sed -nE -e "s/^\\s+(|make|check)depends(|_${CARCH}) = //p" -e '/^\s*pkgname/q' < .SRCINFO)
else
DEPENDS=()