summaryrefslogtreecommitdiff
path: root/src/chroot-tools
diff options
context:
space:
mode:
Diffstat (limited to 'src/chroot-tools')
-rwxr-xr-xsrc/chroot-tools/chcleanup7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/chroot-tools/chcleanup b/src/chroot-tools/chcleanup
index 21c0ec5..0c78989 100755
--- a/src/chroot-tools/chcleanup
+++ b/src/chroot-tools/chcleanup
@@ -62,10 +62,9 @@ if [ -f PKGBUILD ]; then
fi
msg "Cleaning chroot..."
-msg2 "Fetching updated package lists..."
-pacman -Sy || {
- warning "There was an error updating package lists, ignoring."
-}
+
+# Sync the local repo with pacman
+cp /repo/repo.db /var/lib/pacman/sync/repo.db
# Setup the temporary directory
TEMPDIR="$(mktemp --tmpdir -d $(basename $0).XXXXX)"