summaryrefslogtreecommitdiff
path: root/src/devtools/checkpkg.patch
diff options
context:
space:
mode:
Diffstat (limited to 'src/devtools/checkpkg.patch')
-rw-r--r--src/devtools/checkpkg.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/src/devtools/checkpkg.patch b/src/devtools/checkpkg.patch
deleted file mode 100644
index 5cfb794..0000000
--- a/src/devtools/checkpkg.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- checkpkg.in 2014-03-21 13:59:31.849658036 -0400
-+++ checkpkg.ugly 2014-03-21 14:20:52.340291982 -0400
-@@ -1,8 +1,30 @@
- #!/bin/bash
-+# License: Unspecified
-
- shopt -s extglob
-
--m4_include(lib/common.sh)
-+. "$(librelib messages)"
-+
-+usage() {
-+ print 'Usage: %s [-h]' "${0##*/}"
-+ print 'Compare a locally built a package with the one in the repositories.'
-+ echo
-+ prose 'This should be run from a directory containing a
-+ PKGBUILD. It searches for a locally built package
-+ corresponding to the PKGBUILD, and downloads the last
-+ version of that package from the pacman repositories.
-+ It then compares the list of .so files provided by each
-+ version of the package. It does this for each part of
-+ a split package.'
-+}
-+
-+if [[ $1 = '-h' ]]; then
-+ usage
-+ exit 0
-+elif [[ $# -gt 0 ]]; then
-+ usage >&2
-+ exit 1
-+fi
-
- # Source makepkg.conf; fail if it is not found
- if [[ -r '/etc/makepkg.conf' ]]; then
-@@ -17,7 +39,9 @@
- fi
-
- if [[ ! -f PKGBUILD ]]; then
-- die 'This must be run in the directory of a built package.'
-+ error 'This must be run in the directory of a built package.'
-+ usage >&2
-+ exit 1
- fi
-
- . ./PKGBUILD