summaryrefslogtreecommitdiff
path: root/src/devtools/finddeps.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/devtools/finddeps.in')
-rw-r--r--src/devtools/finddeps.in39
1 files changed, 0 insertions, 39 deletions
diff --git a/src/devtools/finddeps.in b/src/devtools/finddeps.in
deleted file mode 100644
index 656fe5a..0000000
--- a/src/devtools/finddeps.in
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/bash
-#
-# finddeps - find packages that depend on a given depname
-#
-
-source @pkgdatadir@/common.sh
-
-match=$1
-
-if [[ -z $match ]]; then
- echo 'Usage: finddeps <depname>'
- echo ''
- echo 'Find packages that depend on a given depname.'
- echo 'Run this script from the top-level directory of your ABS tree.'
- echo ''
- exit 1
-fi
-
-find . -type d | while read d; do
- if [[ -f "$d/PKGBUILD" ]]; then
- unset pkgname depends makedepends optdepends
- . "$d/PKGBUILD"
- for dep in "${depends[@]}"; do
- # lose the version comparator, if any
- depname=${dep%%[<>=]*}
- [[ $depname = $match ]] && echo "$d (depends)"
- done
- for dep in "${makedepends[@]}"; do
- # lose the version comparator, if any
- depname=${dep%%[<>=]*}
- [[ $depname = $match ]] && echo "$d (makedepends)"
- done
- for dep in "${optdepends[@]/:*}"; do
- # lose the version comaparator, if any
- depname=${dep%%[<>=]*}
- [[ $depname = $match ]] && echo "$d (optdepends)"
- done
- fi
-done