summaryrefslogtreecommitdiff
path: root/src/devtools/finddeps.patch
diff options
context:
space:
mode:
Diffstat (limited to 'src/devtools/finddeps.patch')
-rw-r--r--src/devtools/finddeps.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/devtools/finddeps.patch b/src/devtools/finddeps.patch
new file mode 100644
index 0000000..a960ac1
--- /dev/null
+++ b/src/devtools/finddeps.patch
@@ -0,0 +1,33 @@
+--- finddeps.in 2014-03-20 15:55:50.121247884 -0400
++++ finddeps 2014-03-21 00:11:02.573978735 -0400
+@@ -3,18 +3,24 @@
+ # finddeps - find packages that depend on a given depname
+ #
+
+-m4_include(lib/common.sh)
++. $(librelib messages)
+
+ match=$1
+
++usage() {
++ print 'Usage: %s <depname>' "${0##*/}"
++ print 'Find packages that depend on a given depname.'
++ echo
++ prose 'Run this script from the top-level directory of your ABS tree.'
++}
+ if [[ -z $match ]]; then
+- echo 'Usage: finddeps <depname>'
+- echo ''
+- echo 'Find packages that depend on a given depname.'
+- echo 'Run this script from the top-level directory of your ABS tree.'
+- echo ''
++ usage >&2
+ exit 1
+ fi
++if [[ $match = '-h' ]]; then
++ usage
++ exit 0
++fi
+
+ find . -type d | while read d; do
+ if [[ -f "$d/PKGBUILD" ]]; then