summaryrefslogtreecommitdiff
path: root/src/devtools/finddeps.patch
diff options
context:
space:
mode:
Diffstat (limited to 'src/devtools/finddeps.patch')
-rw-r--r--src/devtools/finddeps.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/devtools/finddeps.patch b/src/devtools/finddeps.patch
new file mode 100644
index 0000000..caf2121
--- /dev/null
+++ b/src/devtools/finddeps.patch
@@ -0,0 +1,35 @@
+--- finddeps.in 2014-03-21 13:59:32.249641424 -0400
++++ finddeps.ugly 2014-03-21 14:21:09.949489174 -0400
+@@ -2,19 +2,26 @@
+ #
+ # finddeps - find packages that depend on a given depname
+ #
++# License: Unspecified
+
+-m4_include(lib/common.sh)
++. "$(librelib messages)"
+
+ match=$1
+
++usage() {
++ print 'Usage: %s <depname>' "${0##*/}"
++ print 'Find packages that depend on a given depname.'
++ echo
++ prose 'Run this script from the top-level directory of your ABS tree.'
++}
+ if [[ -z $match ]]; then
+- echo 'Usage: finddeps <depname>'
+- echo ''
+- echo 'Find packages that depend on a given depname.'
+- echo 'Run this script from the top-level directory of your ABS tree.'
+- echo ''
++ usage >&2
+ exit 1
+ fi
++if [[ $match = '-h' ]]; then
++ usage
++ exit 0
++fi
+
+ find . -type d | while read d; do
+ if [[ -f "$d/PKGBUILD" ]]; then