summaryrefslogtreecommitdiff
path: root/src/fullpkg/fullpkg
diff options
context:
space:
mode:
Diffstat (limited to 'src/fullpkg/fullpkg')
-rwxr-xr-xsrc/fullpkg/fullpkg34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/fullpkg/fullpkg b/src/fullpkg/fullpkg
new file mode 100755
index 0000000..9a03b82
--- /dev/null
+++ b/src/fullpkg/fullpkg
@@ -0,0 +1,34 @@
+#!/bin/bash
+# set -x # uncomment for debug
+# Builds packages from ABS recursively. It tries to find dependencies that
+# aren't built or need update and then makepkg them in order.
+
+usage() {
+
+ echo "cd to a dir containing a PKGBUILD and run:"
+ echo "$0 [build_dir]"
+ echo ""
+ echo "This script will check dependencies, build them if possible "
+ echo "and stage the packages on it's repo."
+ echo ""
+ echo "OPTIONS:"
+ echo " -h : this message."
+ echo ""
+ echo "Wrapper for \`fullpkg-find' and \`fullpkg-build'"
+ echo ""
+ exit 1
+
+}
+
+while getopts 'haA:l:nm:' arg; do
+ case "$arg" in
+ h) usage ;;
+ esac
+done
+
+shift $(( OPTIND - 1 ))
+
+build_dir="${1:-$(mktemp -d /tmp/fullpkg.XXXXXX)}"
+fullpkg-find "$build_dir" && fullpkg-build -N "$build_dir"
+
+exit 0