summaryrefslogtreecommitdiff
path: root/src/fullpkg/fullpkg
diff options
context:
space:
mode:
Diffstat (limited to 'src/fullpkg/fullpkg')
-rwxr-xr-xsrc/fullpkg/fullpkg31
1 files changed, 16 insertions, 15 deletions
diff --git a/src/fullpkg/fullpkg b/src/fullpkg/fullpkg
index 7724165..00a9502 100755
--- a/src/fullpkg/fullpkg
+++ b/src/fullpkg/fullpkg
@@ -4,25 +4,26 @@
# aren't built or need update and then makepkg them in order.
usage() {
-
- echo "cd to a dir containing a PKGBUILD and run:"
- echo "$0 [build_dir]"
- echo ""
- echo "This script will check dependencies, build them if possible "
- echo "and stage the packages on it's repo."
- echo ""
- echo "OPTIONS:"
- echo " -h : this message."
- echo ""
- echo "Wrapper for \`fullpkg-find' and \`fullpkg-build'"
- echo ""
- exit 1
-
+ print "Usage: %s [OPTIONS] [BUILD_DIR]" "${0##*/}"
+ print "A (libre)makepkg wrapper that will also build dependencies"
+ echo
+ prose "More directly, it wraps fullpkg-find and fullpkg-build;
+ fullpkg-find finds the dependencies, and sets them up in
+ BUILD_DIR; then fullpkg-build builds them."
+ echo
+ prose "This script will check dependencies, build them if possible and
+ stage the packages on its repo."
+ echo
+ prose "If no BUILD_DIR is specified, it will create a temporary
+ directory."
+ echo
+ print "Options:"
+ flag '-h' "Show this message"
}
while getopts 'h' arg; do
case "$arg" in
- h) usage ;;
+ h) usage; exit 0 ;;
esac
done