summaryrefslogtreecommitdiff
path: root/src/lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile')
-rw-r--r--src/lib/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/lib/Makefile b/src/lib/Makefile
index d7b4049..255bc05 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -10,8 +10,9 @@ include ../../common.mk
common.sh: %: %.in %.top Makefile
@echo "GEN $@"
@{ \
- cat "$*.top" && \
- echo 'if [[ -z $${_INCLUDE_COMMON_SH:-} ]]; then' && \
- echo '_INCLUDE_COMMON_SH=true' && \
- cat "$*.in" && \
- echo 'fi'; } > "$@"
+ cat '$*.top' && \
+ echo && \
+ sed -r -e '/encoding problem/d;/LANG=/d' -e 's/mesg=\$$(.)/mesg="$$(_ "$$\1")"/' '$*.in' && \
+ echo && \
+ cat '$*.bottom' && \
+ :; } > '$@'