summaryrefslogtreecommitdiff
path: root/src/lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile')
-rw-r--r--src/lib/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 495abb1..3d2d8f9 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -27,11 +27,12 @@ common.sh: %: %.in %.top Makefile
# Translate ##########################################################
-libreblacklist.pot: libreblacklist
+libreblacklist.pot: libreblacklist librexgettext
{ \
sed -n '/^# Usage:/,/()/{ /^#/ { =; p; } }' $< | \
sed -r -e 's/^# (.*)/msgid "\1"\nmsgstr ""\n/' \
-e 's/^[0-9]*$$/#. embedded usage text\n#: $<:&/'; \
- $(xgettext-sh-prose); \
- $(xgettext-sh-std); \
+ ./librexgettext $<; \
} | $(pofmt) > $@
+
+librexgettext.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage