summaryrefslogtreecommitdiff
path: root/src/lib/conf.sh.3.ronn
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/conf.sh.3.ronn')
-rw-r--r--src/lib/conf.sh.3.ronn34
1 files changed, 13 insertions, 21 deletions
diff --git a/src/lib/conf.sh.3.ronn b/src/lib/conf.sh.3.ronn
index a2bc862..82f6eed 100644
--- a/src/lib/conf.sh.3.ronn
+++ b/src/lib/conf.sh.3.ronn
@@ -59,10 +59,20 @@ The routines you will likely actually use are:
aren't, it prints a message to configure them in the
configuration files for <SLUG>, and returns with a non-zero
status.
+ * `get_var` <SLUG> <VAR> <DEFAULT>:
+ If <VAR> is set in the configuration for <SLUG>, print it's
+ value, considering environmental variables. If it is not set,
+ return <DEFAULT>. This does NOT work for array variables.
+ * `set_var` <SLUG> <VAR> <VALUE>:
+ Set the variable <VAR> equal to <VALUE> in the configuration file
+ for <SLUG> of highest precedence that already exists, and is
+ writable. If no files fit this description, the routine does
+ nothing and returns a non-zero exit status. This does NOT work
+ for array variables.
-There are also two more routines that are used internally by
-the above. You are unlikely to use them directly, but they might
-be useful for debugging.
+There are two more routines the above routines use internally that are
+used internally by . You are unlikely to use them directly, but they
+might be useful for debugging, or at least describing behavior.
* `list_files` <SLUG>:
Lists (newline-separated) the configuration files that must be
@@ -75,24 +85,6 @@ be useful for debugging.
<PACKAGER> environmental variable is set, the value in the
configuration file is ignored.
-### MAKEPKG.CONF ROUTINES
-
-These two routines exist to get and set individual variables in
-`makepkg.conf`(). See the output of `list_files makepkg` for exactly
-what set of files that refers to.
-
-These routines do NOT work with array settings.
-
- * `get_conf_makepkg` <VAR> <DEFAULT>:
- If <VAR> is set, return it's value, considering environmental
- variables. If it is not set, return <DEFAULT>. The printed
- value is then trailed by a newline.
- * `set_conf_makepkg` <VAR> <VALUE>:
- Set the variable <VAR> equal to <VALUE> in the configuration file
- of highest precedence that already exists, and is writable. If
- no files fit this description, the routine does nothing and
- returns a non-zero exit status.
-
### PKGBUILD ROUTINES
These two routines deal with loading `PKGBUILD`(5) files.