summaryrefslogtreecommitdiff
path: root/src/lib/conf.sh.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/conf.sh.in')
-rw-r--r--src/lib/conf.sh.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/conf.sh.in b/src/lib/conf.sh.in
index 8fae514..8042f8f 100644
--- a/src/lib/conf.sh.in
+++ b/src/lib/conf.sh.in
@@ -196,6 +196,7 @@ unset_PKGBUILD() {
# of a function that we get to unset anyway. So it can't
# clash with anything!
mksource() {
+ # For each arg, `unset -v` all variables matching ${arg} and ${arg}_*
local v
for v in "$@"; do
unset -v "$v" $(declare -p|sed -rn "s/^declare -\S+ (${v}_[a-zA-Z0-9_]*)=.*/\1/p")