summaryrefslogtreecommitdiff
path: root/src/librediff
diff options
context:
space:
mode:
Diffstat (limited to 'src/librediff')
-rwxr-xr-xsrc/librediff60
1 files changed, 26 insertions, 34 deletions
diff --git a/src/librediff b/src/librediff
index 1f39eb9..6dbe41b 100755
--- a/src/librediff
+++ b/src/librediff
@@ -20,46 +20,38 @@
# You should have received a copy of the GNU General Public License
# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
-usage() {
- echo "Usage: $0 <pkgname> [<pkgname2> ...]"
- echo "Requirements:"
- echo "* Have a <pkgname>/ directory with nonfree build scripts inside"
- echo "* Have a <pkgname>-libre/ directory with libre build scripts inside"
-}
+. /etc/libretools.conf
-# Load custom config or system-wide config
-custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
-if [ -e $custom_config ]; then
- source $custom_config
-else
- source /etc/libretools.conf
-fi
+cmd=${0##*/}
-# Print usage if no package has been given
-[[ -z "$@" ]] && {
- usage
- exit 1
+usage() {
+ echo "Usage: $cmd <pkgname> [<pkgname2> ...]"
+ echo "Requirements:"
+ echo " * Have a <pkgname>/ directory with nonfree build scripts inside"
+ echo " * Have a <pkgname>-libre/ directory with libre build scripts inside"
}
+main() {
+ local packages=("$@")
+ if [[ ${packages[#]} = 0 ]]; then
+ usage
+ exit 1
+ fi
-for package in $@; do
-# Continue on errors
- [[ ! -d ./${package} || ! -d ./${package}-libre ]] && {
- error "no matching ${package} and ${package}-libre found"
- continue
- }
-
- [[ ! -f ./${package}/PKGBUILD || ! -f ./${package}-libre/PKGBUILD ]] && {
- error "no matching PKGBUILDs found for ${package}-libre"
- continue
- }
+ for package in "${packages[@]}"; do
+ if [[ ! -f ./${package}/PKGBUILD || ! -f ./${package}-libre/PKGBUILD ]]
+ then
+ error "Build scripts not found for ${package}(-libre)"
+ else
- source ./${package}-libre/PKGBUILD
- [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
+ . ./${package}-libre/PKGBUILD
+ [[ -z ${pkgbase} ]] && pkgbase=${pkgname}
-# Generate a diff file, no -r since we don't want to patch src/ nor pkg/
- diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
+ # Generate a diff file, no -r since we don't want to patch src/ nor pkg/
+ diff -auN ${package} ${package}-libre > $PATCHDIR/${pkgbase}-${pkgver}-${pkgrel}.patch
+ done
-done
+ exit 0
+}
-exit 0
+main "$@"