summaryrefslogtreecommitdiff
path: root/src/librefetch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/librefetch/Makefile')
-rw-r--r--src/librefetch/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/src/librefetch/Makefile b/src/librefetch/Makefile
index dcb64dc..b28e96e 100644
--- a/src/librefetch/Makefile
+++ b/src/librefetch/Makefile
@@ -1,5 +1,13 @@
-progs = librefetch-install
-confs = librefetch-makepkg.conf
-libexecs = $(shell find librefetchdir -type f -executable)
-libs = $(shell find librefetchdir -type f -not -executable)
-include ../../common.mk
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
+
+install-bins = librefetch librefetch-install
+install-confs += librefetch-makepkg.conf
+install-libexecs += $(filter librefetchdir/%,$(detect-exec))
+install-libs += $(filter-out $(install-libexecs),$(filter librefetchdir/%,$(detect-all)))
+pots = $(install-bins)
+
+$(outdir)/librefetch-install: $(var)pkgconfdir
+$(outdir)/librefetch-makepkg.conf: $(var)bindir
+
+include $(topsrcdir)/automake.tail.mk